import Foundation
let pattern = #"\w+$ 7.000.000.000"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
end of string COINGBIT
0x18a0c976040e8fd9e529b8b363150b201606396e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}