import re
regex = re.compile(r"\w+$ 7.000.000.000")
test_str = ("end of string COINGBIT \n"
"0x18a0c976040e8fd9e529b8b363150b201606396e")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")