package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+$ 7.000.000.000`)
var str = `end of string COINGBIT
0x18a0c976040e8fd9e529b8b363150b201606396e`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}