$re = '/\w+$ 7.000.000.000/';
$str = 'end of string COINGBIT
0x18a0c976040e8fd9e529b8b363150b201606396e';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);