re = /\w+$ 7.000.000.000/
str = 'end of string COINGBIT
0x18a0c976040e8fd9e529b8b363150b201606396e'
# Print the match result
str.match(re) do |match|
puts match.to_s
end