#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:\$|usd)?(?:\d+\.?\d*)(?:\$|usd)?$"
Local $sString = "$290" & @CRLF & _
"USD240" & @CRLF & _
"$234.45" & @CRLF & _
"234.5$" & @CRLF & _
"234.6usd" & @CRLF & _
"$...1....11.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")