// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:\$|usd)?(?:\d+\.?\d*)(?:\$|usd)?$").unwrap();
let string = "$290
USD240
$234.45
234.5$
234.6usd
$...1....11..";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}