$re = '/^(?:\$|usd)?(?:\d+\.?\d*)(?:\$|usd)?$/mi';
$str = '$290
USD240
$234.45
234.5$
234.6usd
$...1....11..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);