package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:\$|usd)?(?:\d+\.?\d*)(?:\$|usd)?$`)
var str = `$290
USD240
$234.45
234.5$
234.6usd
$...1....11..`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}