import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\$|usd)?(?:\\d+\\.?\\d*)(?:\\$|usd)?$";
final String string = "$290\n"
+ "USD240\n"
+ "$234.45\n"
+ "234.5$\n"
+ "234.6usd\n"
+ "$...1....11..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}