using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\$|usd)?(?:\d+\.?\d*)(?:\$|usd)?$";
string input = @"$290
USD240
$234.45
234.5$
234.6usd
$...1....11..";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}