#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,5}$|^\d{0,5}\.\d{1,4}$"
Local $sString = "123" & @CRLF & _
"12345" & @CRLF & _
"12345.2156" & @CRLF & _
"123456" & @CRLF & _
"123456.12" & @CRLF & _
"12345.12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")