import re
regex = re.compile(r"^\d{1,5}$|^\d{0,5}\.\d{1,4}$", flags=re.MULTILINE)
test_str = ("123\n"
"12345\n"
"12345.2156\n"
"123456\n"
"123456.12\n"
"12345.12345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")