re = /^\d{1,5}$|^\d{0,5}\.\d{1,4}$/m
str = '123
12345
12345.2156
123456
123456.12
12345.12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end