package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,5}$|^\d{0,5}\.\d{1,4}$`)
var str = `123
12345
12345.2156
123456
123456.12
12345.12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}