$re = '/^\d{1,5}$|^\d{0,5}\.\d{1,4}$/m';
$str = '123
12345
12345.2156
123456
123456.12
12345.12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);