const regex = /^\d{1,5}$|^\d{0,5}\.\d{1,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,5}$|^\\d{0,5}\\.\\d{1,4}$', 'gm')
const str = `123
12345
12345.2156
123456
123456.12
12345.12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}