#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*(\1)_END\*)"
Local $sString = "/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*" & @CRLF & _
"/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")