import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\*([a-zA-Z0-9]+)_START\\*\\/(.*?)\\/\\*(\\1)_END\\*)";
final String string = "/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*\n"
+ "/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}