re = /(?=\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*(\1)_END\*)/
str = '/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*
/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end