const regex = /(?=\*([a-zA-Z0-9]+)_START\*\/(.*?)\/\*(\1)_END\*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\*([a-zA-Z0-9]+)_START\\*\\\/(.*?)\\\/\\*(\\1)_END\\*)', 'g')
const str = `/*tag1_START*/ some content /*tag1_END*/ other text /*tag2_START*/ some content /*tag2_END*
/*tag3_START*/ some /*tag4_START*/ content /*tag3_END*/ other /*tag4_END*/ content`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}