using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"User-Name=(?:host\/)?(?:[A-Za-z]{3}\\\\)?([a-zA-Z0-9\-\\\_]+)";
string input = @"Syslog Example 1: User-Name=user1.domain.com
Syslog Example 2: User-Name=user1
Syslog Example 3: User-Name=dmn\user1
Syslog Example 4: User-Name=dmn\\user1
Syslog Example 5: User-Name=user1@domain.com
Syslog Example 6: User-Name=host/user1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}