use strict;
my $str = 'Syslog Example 1: User-Name=user1.domain.com
Syslog Example 2: User-Name=user1
Syslog Example 3: User-Name=dmn\\user1
Syslog Example 4: User-Name=dmn\\\\user1
Syslog Example 5: User-Name=user1@domain.com
Syslog Example 6: User-Name=host/user1';
my $regex = qr/User-Name=(?:host\/)?(?:[A-Za-z]{3}\\\\)?([a-zA-Z0-9\-\\\_]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}