import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "User-Name=(?:host\\/)?(?:[A-Za-z]{3}\\\\\\\\)?([a-zA-Z0-9\\-\\\\\\_]+)";
final String string = "Syslog Example 1: User-Name=user1.domain.com\n\n"
+ "Syslog Example 2: User-Name=user1\n\n"
+ "Syslog Example 3: User-Name=dmn\\user1\n\n"
+ "Syslog Example 4: User-Name=dmn\\\\user1\n\n"
+ "Syslog Example 5: User-Name=user1@domain.com\n\n"
+ "Syslog Example 6: User-Name=host/user1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}