import Foundation
let pattern = #"User-Name=(?:host\/)?(?:[A-Za-z]{3}\\\\)?([a-zA-Z0-9\-\\\_]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Syslog Example 1: User-Name=user1.domain.com
Syslog Example 2: User-Name=user1
Syslog Example 3: User-Name=dmn\user1
Syslog Example 4: User-Name=dmn\\user1
Syslog Example 5: User-Name=user1@domain.com
Syslog Example 6: User-Name=host/user1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)