package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)User-Name=(?:host\/)?(?:[A-Za-z]{3}\\\\)?([a-zA-Z0-9\-\\\_]+)`)
var str = `Syslog Example 1: User-Name=user1.domain.com
Syslog Example 2: User-Name=user1
Syslog Example 3: User-Name=dmn\user1
Syslog Example 4: User-Name=dmn\\user1
Syslog Example 5: User-Name=user1@domain.com
Syslog Example 6: User-Name=host/user1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}