using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?""id"": (\d+).*?(""exclusions"": \[.*?|""desig"").*?{";
string input = @" {
""id"": 5229,
""Type"": B,
""exclusions"": [
{
""id"": 3486,
""desig"": ""A"",
""price"": 101,
},
{
""id"": 3489,
""desig"": ""A"",
""price"": 101,
}]},
{
""id"": 5239,
""Type"": B,
""exclusions"": []
}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}