const regex = /.*?"id": (\d+).*?("exclusions": \[.*?|"desig").*?{/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?"id": (\\d+).*?("exclusions": \\[.*?|"desig").*?{', 'gs')
const str = ` {
"id": 5229,
"Type": B,
"exclusions": [
{
"id": 3486,
"desig": "A",
"price": 101,
},
{
"id": 3489,
"desig": "A",
"price": 101,
}]},
{
"id": 5239,
"Type": B,
"exclusions": []
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}