// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s).*?"id": (\d+).*?("exclusions": \[.*?|"desig").*?{"#).unwrap();
let string = " {
\"id\": 5229,
\"Type\": B,
\"exclusions\": [
{
\"id\": 3486,
\"desig\": \"A\",
\"price\": 101,
},
{
\"id\": 3489,
\"desig\": \"A\",
\"price\": 101,
}]},
{
\"id\": 5239,
\"Type\": B,
\"exclusions\": []
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}