package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*?"id": (\d+).*?("exclusions": \[.*?|"desig").*?{`)
var str = ` {
"id": 5229,
"Type": B,
"exclusions": [
{
"id": 3486,
"desig": "A",
"price": 101,
},
{
"id": 3489,
"desig": "A",
"price": 101,
}]},
{
"id": 5239,
"Type": B,
"exclusions": []
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}