#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[[0-9,-]+\]"
Local $sString = "product[attribute][1][0][value]" & @CRLF & _
"product[attribute][1][1][value]" & @CRLF & _
"product[attribute][1][2][value]" & @CRLF & _
"product[attribute][2][1][value]" & @CRLF & _
"product[attribute][2][2][value]" & @CRLF & _
"product[attribute][2][3][value]" & @CRLF & _
"product[attribute][2][4][value]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")