using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[0-9,-]+\]";
string input = @"product[attribute][1][0][value]
product[attribute][1][1][value]
product[attribute][1][2][value]
product[attribute][2][1][value]
product[attribute][2][2][value]
product[attribute][2][3][value]
product[attribute][2][4][value]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}