package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[0-9,-]+\]`)
var str = `product[attribute][1][0][value]
product[attribute][1][1][value]
product[attribute][1][2][value]
product[attribute][2][1][value]
product[attribute][2][2][value]
product[attribute][2][3][value]
product[attribute][2][4][value]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}