import Foundation
let pattern = #"\[[0-9,-]+\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
product[attribute][1][0][value]
product[attribute][1][1][value]
product[attribute][1][2][value]
product[attribute][2][1][value]
product[attribute][2][2][value]
product[attribute][2][3][value]
product[attribute][2][4][value]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)