// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[[0-9,-]+\]").unwrap();
let string = "product[attribute][1][0][value]
product[attribute][1][1][value]
product[attribute][1][2][value]
product[attribute][2][1][value]
product[attribute][2][2][value]
product[attribute][2][3][value]
product[attribute][2][4][value]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}