$re = '/\[[0-9,-]+\]/';
$str = 'product[attribute][1][0][value]
product[attribute][1][1][value]
product[attribute][1][2][value]
product[attribute][2][1][value]
product[attribute][2][2][value]
product[attribute][2][3][value]
product[attribute][2][4][value]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);