#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "=(?=.*)(?=(?:'.*?'|".*?"|`.*?`).*?)"
Local $sString = "image.inside {" & @CRLF & _
" sshagent(credentials: ['ssh-creds']) {" & @CRLF & _
" env.GIT_SSH_COMMAND1="ssh -T -o StrictHostKeyChecking=no"" & @CRLF & _
" env.GIT_SSH_COMMAND2='ssh -T -o StrictHostKeyChecking=no'" & @CRLF & _
" env.GIT_SSH_COMMAND3=`ssh -T -o StrictHostKeyChecking=no`" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")