$re = '/=(?=.*)(?=(?:\'.*?\'|".*?"|`.*?`).*?)/';
$str = 'image.inside {
sshagent(credentials: [\'ssh-creds\']) {
env.GIT_SSH_COMMAND1="ssh -T -o StrictHostKeyChecking=no"
env.GIT_SSH_COMMAND2=\'ssh -T -o StrictHostKeyChecking=no\'
env.GIT_SSH_COMMAND3=`ssh -T -o StrictHostKeyChecking=no`
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);