import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=(?=.*)(?=(?:'.*?'|\".*?\"|`.*?`).*?)";
final String string = "image.inside {\n"
+ " sshagent(credentials: ['ssh-creds']) {\n"
+ " env.GIT_SSH_COMMAND1=\"ssh -T -o StrictHostKeyChecking=no\"\n"
+ " env.GIT_SSH_COMMAND2='ssh -T -o StrictHostKeyChecking=no'\n"
+ " env.GIT_SSH_COMMAND3=`ssh -T -o StrictHostKeyChecking=no`\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}