re = /=(?=.*)(?=(?:'.*?'|".*?"|`.*?`).*?)/
str = 'image.inside {
sshagent(credentials: [\'ssh-creds\']) {
env.GIT_SSH_COMMAND1="ssh -T -o StrictHostKeyChecking=no"
env.GIT_SSH_COMMAND2=\'ssh -T -o StrictHostKeyChecking=no\'
env.GIT_SSH_COMMAND3=`ssh -T -o StrictHostKeyChecking=no`
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end