using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=(?=.*)(?=(?:'.*?'|"".*?""|`.*?`).*?)";
string input = @"image.inside {
sshagent(credentials: ['ssh-creds']) {
env.GIT_SSH_COMMAND1=""ssh -T -o StrictHostKeyChecking=no""
env.GIT_SSH_COMMAND2='ssh -T -o StrictHostKeyChecking=no'
env.GIT_SSH_COMMAND3=`ssh -T -o StrictHostKeyChecking=no`
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}