const regex = /=(?=.*)(?=(?:'.*?'|".*?"|`.*?`).*?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=(?=.*)(?=(?:\'.*?\'|".*?"|`.*?`).*?)', 'g')
const str = `image.inside {
sshagent(credentials: ['ssh-creds']) {
env.GIT_SSH_COMMAND1="ssh -T -o StrictHostKeyChecking=no"
env.GIT_SSH_COMMAND2='ssh -T -o StrictHostKeyChecking=no'
env.GIT_SSH_COMMAND3=\`ssh -T -o StrictHostKeyChecking=no\`
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}