import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.+(?<stringOfInterest>.*)";
final String string = ".. Adobe Flash Player ActiveX DSC \n"
+ "... Adobe Flash Player NPAPI\n"
+ "... Adobe Reader XI (..) \n"
+ ".. Adobe Shockwave Player \n"
+ "... Atmel Touchscreen Power \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}