re = /\.+(?<stringOfInterest>.*)/
str = '.. Adobe Flash Player ActiveX DSC
... Adobe Flash Player NPAPI
... Adobe Reader XI (..)
.. Adobe Shockwave Player
... Atmel Touchscreen Power
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end