using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^6(?:011|5[0-9]{2})[0-9]{12,15}$";
string input = @"6011111111111117
6011000990139424
60110009901394245
6011000990139424123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}