re = /^6(?:011|5[0-9]{2})[0-9]{12,15}$/m
str = '6011111111111117
6011000990139424
60110009901394245
6011000990139424123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end