import re
regex = re.compile(r"^6(?:011|5[0-9]{2})[0-9]{12,15}$", flags=re.MULTILINE)
test_str = ("6011111111111117\n"
"6011000990139424\n"
"60110009901394245\n"
"6011000990139424123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")