const regex = /^6(?:011|5[0-9]{2})[0-9]{12,15}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^6(?:011|5[0-9]{2})[0-9]{12,15}$', 'gm')
const str = `6011111111111117
6011000990139424
60110009901394245
6011000990139424123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}