package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^6(?:011|5[0-9]{2})[0-9]{12,15}$`)
var str = `6011111111111117
6011000990139424
60110009901394245
6011000990139424123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}