// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^6(?:011|5[0-9]{2})[0-9]{12,15}$").unwrap();
let string = "6011111111111117
6011000990139424
60110009901394245
6011000990139424123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}